...

Crear Guiones FileMaker más fácilmente

by user

on
Category: Documents
35

views

Report

Comments

Transcript

Crear Guiones FileMaker más fácilmente
Crear Guiones FileMaker
más fácilmente
¡Trabaje más rápidamente automatizando tareas
clave mediante el uso de los guiones FileMaker!
Crear Guiones FileMaker más fácilmente
1
Crear Guiones FileMaker más fácilmente
¡Trabaje más rápidamente automatizando tareas clave mediante el uso de los guiones FileMaker!
No necesita ser un programador experto para poder aprovechar las capacidades de la creación
de guiones de FileMaker Pro que le ayudarán a automatizar tareas, de forma que usted pueda
hacer más cada día.
Este artículo, juntamente con el FileMaker Graphics Pack, le ayuda a empezar y a poder ver los
resultados inmediatamente. ¡En minutos!
Paso 1: Descargue el FileMaker Graphics Pack
El FileMaker Graphics Pack está disponible vía descarga para los clientes de FileMaker que han
comprado y registrado su software dentro del periodo de promoción especificado.
•
Si usted no ha descargado todavía su FileMaker Graphics Pack, por favor haga clic en
el vínculo de descarga que encontrará en el e-mail de Confirmación de Registro de
FileMaker que ya debería haber recibido.
Paso 2: Ejecute FileMaker Pro 10 o FileMaker Pro 10 Advanced
Paso 3: Abra la plantilla Artículos del inventario de las Soluciones Iniciales
•
Seleccione Nueva Base de datos desde el menú Archivo de FileMaker.
•
Seleccione Crear una base de datos mediante una Solución inicial.
•
Seleccione, desde la categoría Negocio-Personas y Activos, la plantilla llamada “Artículos
del inventario.fp7”
•
Haga clic en Aceptar.
Crear Guiones FileMaker más fácilmente
2
Si no le aparece la pantalla detallada anteriormente cuando selecciona crear nueva base de
datos, seleccione en Preferencias desde el menú Edición (Windows) o FileMaker Pro (Mac) y
marque la casilla de verificación “ Mostrar pantalla de Inicio rápido de FileMaker”.
•
Usted debería visualizar en pantalla una base de datos de Artículos del inventario en
blanco.
•
Haga clic en “Editar presentación” para acceder al modo Presentación, como se muestra a
continuación.
Paso 4: Inserte una imagen desde el FileMaker Graphics Pack Ahora usted abrirá una segunda base de datos, la base de datos FileMaker Graphics Pack, que
contiene todos los botones e iconos para escoger.
• Seleccione Abrir desde el menú Archivo.
•
Navegue hacia donde ha guardado la base de datos Graphics Pack descomprimida,
llamada FM_graphics_pack.fp7.
Crear Guiones FileMaker más fácilmente
3
¡Atención! Si usted no ha descomprimido todavía el archivo, el archivo descargado se llama
FM_graphics_pack.zip. Simplemente haga doble clic sobre la base para descomprimirla, de
forma que pueda abrirla en FileMaker Pro 10.
•
Busque un registro que contenga un botón de “Guardar como PDF” que le guste,
seleccionando la Vista Lista o Vista Tabla y escribiendo “pdf” en el cuadro de texto de la
derecha.
•
Ahora simplemente arrastre el botón desde la base de de datos Graphics Pack a la base
Artículos del inventario y suéltelo donde usted desea que aparezca.
Paso 5: Adjunte un guión FileMaker al gráfico.
•
Haga un clic con el botón derecho del ratón encima del gráfico para que aparezca el
diálogo Configuración del botón.
•
Desplácese por la lista de opciones a la izquierda de la pantalla hasta la sección Registros,
y seleccione Guardar Registros como PDF.
•
En el apartado de Opciones, marque la casilla de verificación Especificar Opciones.
Aparecerá el cuadro de diálogo Opciones de “Guardar registros como PDF”.
•
Seleccione la opción “Registros que se están visualizando” y haga clic en OK.
•
Haga clic en Aceptar en el cuadro de diálogo Configuración del botón.
Crear Guiones FileMaker más fácilmente
4
Paso 6: Hágalo funcionar
Ahora usted tiene un botón que funciona en su presentación. Vamos a verlo en acción:
• Haga clic en “Abandonar presentación” para volver al modo Visualizar.
• Añada un registro de prueba a su base de datos Artículos del inventario.
• Haga clic en su nuevo botón añadido, usted verá aparecer el cuadro de diálogo Guardar
registros como PDF si todo funciona correctamente.
¡Enhorabuena! Ha añadido con éxito un guión automatizado a su base de datos que guardará,
enviará e imprimirá registros en formato PDF.
¿Qué es lo siguiente?
Ahora que ya sabe lo fácil que es añadir botones y guiones a una base de datos de prueba, usted
está listo para personalizar sus propias soluciones.
Primero, haga una copia de seguridad de su base de datos. Después siga los pasos indicados
anteriormente, seleccionando cualquiera de los guiones disponibles de FileMaker. Usted puede
Crear Guiones FileMaker más fácilmente
5
incluso combinar guiones o crear el suyo propio para hacer que su base de datos funcione de la
forma más automática. ¡Cómo nunca había imaginado antes!
A continuación están detallados, en orden alfabético, todos los guiones predefinidos en FileMaker
Pro 10 para ayudarle a mejorar cada día más.
A, B, C
Abrir archivo
Abrir Ayuda
Abrir Buscar/reemplazar
Abrir Compartir
Abrir Editar búsquedas guardadas
Abrir Gestionar base de datos
Abrir Gestionar fuentes de datos
Abrir Gestionar listas de valores
Abrir Opciones de archivo
Abrir preferencias
Abrir registro/petición
Abrir remoto
Abrir ScriptMaker
Abrir URL
Activar cuenta
Actualizar enlace (Windows)
Ajustar ventana
Ampliar conjunto encontrado
Añadir cuenta
Borrar
Cambiar búsqueda anterior
Cambiar contraseña
Cerrar archivo
Cerrar ventana
Comentario
Comprobar conjunto hallado
Comprobar registro
Comprobar selección
Configurar impresión
Configurar siguiente valor secuencial
Configurar visualizador Web
Congelar ventana
Consignar registros/peticiones
Convertir archivo
Copiar
Copiar registro/petición
Copiar todos los registros/peticiones
Corregir palabra
Cortar
D
Deshacer/repetir
Desordenar registros
Desplazar ventana
Detener guión
Duplicar registro/petición
E, F
Editar diccionario del usuario
Ejecutar AppleScript (Mac OS)
Ejecutar Buscar/reemplazar
Ejecutar búsqueda
Ejecutar guión
Ejecutar SQL
Eliminar cuenta
Eliminar fila del portal
Eliminar registro/petición
Eliminar todos los registros
Else
Else If
End If
End Loop
Enviar correo
Enviar ejecución DDE (Windows)
Enviar evento (Mac OS)
Enviar evento (Windows)
Establecer campo
Establecer campo por nombre
Establecer captura de errores
Establecer multiusuario
Establecer nivel de ampliación
Establecer selección
Establecer tìtulo de ventana
Establecer uso de formatos del sistema
Establecer variable
Exit Loop If
Exportar contenido del campo
Exportar registros
Crear Guiones FileMaker más fácilmente
6
G
Guardar registros como Excel
Guardar registros como PDF
Guardar una copia como
Mover/Cambiar tamaño de ventana
Nueva ventana
Nuevo archivo
Nuevo registro/petición
H, I, J, K
Hablar (Mac OS)
If
Importar registros
Imprimir
Insertar archivo
Insertar desde índice
Insertar desde último visitado
Insertar fecha actual
Insertar hora actual
Insertar imagen
Insertar nombre del usuario actual
Insertar objeto (Windows)
Insertar QuickTime
Insertar resultado calculado
Insertar texto
Instalar guión OnTimer
Instalar juego de menús
Ir a la fila del portal
Ir a la presentación
Ir a objeto
Ir al campo
Ir al campo anterior
Ir al campo siguiente
Ir al registro relacionado
Ir al registro/petición/página
O
Omitir múltiples registros
Omitir registro
Opciones de ortografìa
Ordenar registros
Organizar todas las ventanas
P, Q
Pausar/reanudar guión
Pegar
Permitir barras de herramientas
Permitir cancelación del usuario
Pitar
R
Recuperar archivo
Reemplazar contenido del campo
Refrescar ventana
Repetir acceso
Restablecer contraseña de cuenta
Restablecer registro/petición
Restringir conjunto encontrado
L, M, N
Loop
Marcar
Modo Buscar
Modo Vista previa
Modo Visualizar
Mostrar cuadro de diálogo personalizado
Mostrar sólo omitidos
Mostrar todos los registros
Mostrar/ocultar área de estado
Mostrar/Ocultar regla de texto
S, T, U
Salir de la aplicación
Salir del guión
Seleccionar diccionarios
Seleccionar todo
Seleccionar ventana
V, W, X, Y, Z
Vaciar caché a disco
Ver como
Volver a buscar contenido de campo
© 2009 FileMaker, Inc. Todos los derechos reservados. FileMaker es un marca de FileMaker, Inc. Registrada en Estados Unidos
y otros países. Las personas y compañías mencionadas en los ejemplos son completamente ficticias, y cualquier parecido con
personas y compañías reales es mera coincidencia.
Crear Guiones FileMaker más fácilmente
7
Fly UP